Delay in deliverability to the UK
Incident Report for SMS Broadcast UK
Resolved
This incident has been resolved.
Posted Jul 18, 2023 - 08:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2023 - 08:35 UTC
Investigating
We are currently investigating delays in deliverability to the UK.
Posted Jul 18, 2023 - 08:13 UTC
This incident affected: Outbound SMS.